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Reed-Solomon Lab
Background

Reed-Solomon is a forward error correction (FEC) algorithm that enables the correction of errors injected into a data 
stream from a noisy channel. A data stream is broken up into blocks (called data packets) of the same number of bytes 
(each byte is called a data symbol). These data packets are then passed to the Reed-Solomon encoder, which adds 
several bytes (called check symbols) to the end of each data packet. Together, the data and check symbols make up a 
codeword. 

The Reed-Solomon decoder uses the check symbols at the end of each codeword to correct any data symbols that were 
corrupted during transmission. The number of errors the decoder can correct is dependent on the number of check 
symbols that are in the codeword. For every two check symbols in a codeword, the decoder can correct one data symbol. 
Therefore, if there are 16 check symbols in a codeword, the decoder can correct 8 errors.

The designer can specify the number of data symbols and check symbols in each codeword. Depending on how you 
configure your system, there are various trade-offs to using different numbers of data and check symbols. For example, 
if you want the maximum bandwidth possible, you should add the fewest number of check symbols to each data 
packet. In contrast, if flawless data transmission is more important then overall throughput, you should add as many 
check symbols to each data packet as possible. 

In this lab you will build an FEC system using the Reed-Solomon compiler MegaCore® function and the Stratix™ 

EP1S25 DSP development board or Stratix EP1S80 DSP development board. 

■ Exercise 1—This exercise shows you how to build a Reed-Solomon encoder that conforms to the digital video 
broadcast (DVB) standard.

■ Exercise 2—This exercise shows you how to build a decoder that receives the output from the encoder you built in 
exercise 1. You will add errors before simulation to see how the decoder handles them.

■ Exercise 3—In this exercise, you will use an Altera-provided Windows application and the DSP development board 
to experiment with sending data through a Reed-Solomon encoder/decoder. 

Before You Begin

These instructions assume that you have already installed the software provided with the DSP Development Kit, Stratix 
Edition or DSP Development Kit, Stratix Professional Edition onto your PC. If you have not done so, refer to the DSP 
Development Kit, Stratix & Stratix Professional Edition Getting Started User Guide for installation instructions. You must 
also have the following software installed on your PC:

■ Quartus® II version 2.2 (limited edition or a full version)

1 This white paper assumes that you have installed the Quartus II software into the default location.

Exercise 1: Build a Reed-Solomon Encoder

This exercise shows you how to build a Reed-Solomon encoder that conforms to the DVB standard. You will simulate 
your encoder and view the results to see that the appropriate number of check symbols were added to the data packets. 
This exercise includes the following steps:

1. Create a new Quartus II project.

2. Generate a Reed-Solomon encoder using the wizard interface.
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3. Add input and output pins to your design.

4. Compile the design.

5. Simulate the design.

6. View the simulation results.

1. Create a New Quartus II 2.2 Project

In the Quartus II software, a “project“ consists of the complete set of design files, assignment files, simulation files, 
system settings (including user libraries), and hierarchy information for a design. To build a design, you must first 
create a project. Perform the following steps to create a Block Design File (.bdf) and a Quartus II project.

1-1. Choose Programs > Altera > Quartus II 2.2 Limited Edition (Windows Start menu).

1-2. Choose File > New.

1-3. Select Block Diagram/Schematic File in the Device Design Files tab.

1-4. Click OK. A new Block Diagram/Schematic File (.bdf) displays.

1-5. Choose File > Save As.

1-6. Browse to the c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise1 directory.

1-7. Enter rs_encoder.bdf in the File name box.

1-8. Make sure the Create a new project based on this file option is turned on (it is on by default).

1-9. Click Save.

1-10. Click Yes in the Quartus II message box that asks if you want to create a new project.

1-11. Click Next in the New Project Wizard: Introduction. 

1 The New Project Wizard: Introduction page has the Don’t show me this introduction again option. 
You will only see this page if you have not (or someone else has not) previously turned this option on.

1-12. The New Project Wizard: Directory, Name, and Top-Level Entity page should be filled in based on the name 
and location in which you saved your BDF. Click Next.

1-13. In the New Project Wizard: Add Files page, click the User Library Pathnames button.

1-14. Click the Browse (...) button.

1-15. Browse to the directory in which the Reed-Solomon compiler was installed. The default is 
c:\MegaCore\reed-solomon_compiler-v3.3.4.

1-16. Browse to the lib directory.

1-17. Click Open.

1-18. Click OK.

Page 3 is displayed. This page of the New Project Wizard allows you to set up EDA tools. 
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1-19. Because these tools are not needed at this time, click Next when this page is displayed.

Page 4 is displayed, and prompts you to select a device to target.

1-20.  Select the Stratix option.

Page 5 is displayed, and prompts you to assign a particular device.

1-21. Because it’s unnecessary to assign a particular device, click Next when this page is displayed.

1-22. Click Next to view a summary of your project.

1-23. Click Finish.

Figure 1 shows a screen shot of the Quartus II software after you have created the project.

Figure 1. Quartus II Screen Shot

2. Generate a Reed-Solomon Encoder Using the Wizard Interface

You will now build a Reed-Solomon encoder design in the blank BDF you just created. First, you will create a 
Reed-Solomon encoder function using a wizard interface and then you will add pins to transfer the relevant data off 
chip. Perform the following steps to build the design.

1 If the rs_encoder.bdf file that you created earlier is not open, then open it by choosing the Open command 
(File menu).

2-1. Choose the Edit > Insert Symbol command.

2-2. Click the MegaWizard Plug-In Manager button. 

2-3. Turn on the Create a new custom megafunction variation option and click Next. 

Hierarchy
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Status
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Window

Current
File Open
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Editing
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You can select the IP block that you would like to use and the language in which you want it to be instantiated.

2-4. Expand the DSP folder and then the Error Detection/Correction folder in the Available Megafunctions box.

2-5. Select RS Compiler v3.3.1. 

2-6. Choose the language of the output files you want to create. The wizard creates a file in the language of your 
choice that instantiates the Reed-Solomon encoder. 

1 For the purposes of this lab, it does not matter which language you choose. However, specifying a 
language is a convenient way to ensure compatibility within a design. For example, if you write your 
design in Verilog HDL, you can choose Verilog HDL for the instantiation file and, therefore, not have a 
file in another language instantiated in your top-level design file.

The What name do you want for the output file? box should contain the name of the directory in which you 
created your project. 

2-7. If the What name do you want for the output file? box does contain the correct directory name, type 
rs_encoder_block after the directory. 

2-8. If the What name do you want for the output file? box does not contain the correct directory name, click 
Browse and browse to the directory in which you created your project. Type rs_encoder_block in the File 
name box and click Save.

2-9. Click Next.

On this page you can choose the architecture of your Reed-Solomon core and whether you want an encoder or 
decoder. 

2-10. Select the Encoder option and click Next. 

On this page, you specify the parameters based on the type of FEC system you want to build. 

2-11. Click the DVB Standard button, which automatically sets the number of codewords and check-symbols to 
match the DVB standard.

You are now finished choosing ‘Wizard’ settings. 

2-12. Click Finish to exit the Wizard, or click Next to view the remaining wizard pages. If you click Finish, skip to 
step 16.

Page 3 includes an option to create a vector file, and (if a decoder is being built) this page shows the name of 
the memory file and throughput calculator. 

2-13. Click Next.

Page 4 shows the ordering codes you would use to purchase a license for the core you just configured. 

2-14. Click Next.

Page 5 shows the Wizard output files and where they will be saved. 

2-15. Click Finish.

2-16. Click OK, and then click the insertion point to insert your symbol into the Block Editor window. 
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3. Add Input & Output Pins to Your Design

Now that you have built the encoder, you must assign pins so that the signals go off chip. However, in the lab you will 
only simulate the signals. The Quartus II software compiles a design such that the smallest amount of logic is used to 
implement the functionality of the output pin signals based on the input pin signals. Therefore, if you do not add pins, 
your design will have no logic after compilation. Add input and output pins to the design by performing the following 
steps:

3-1. Choose Edit > Insert Symbol.

3-2. Enter input in the Name box. The Input symbol appears.

3-3. Click OK and click the insertion point to insert the symbol into the Block Editor window.

You can make connections in a BDF by positioning symbols next to each other so that the lines are touching 
(When you move one of the blocks away from the other, a connection line appears.), or by drawing a line 
between the two ports you want to connect. When you point to the line on an input/output port, it turns into a 
drawing tool and allows you to draw a line. 

3-4. Connect the input port rsin[8..1] to the Input symbol at the top left of the Reed-Solomon block. See Figure 2.

Figure 2. Connect the Symbols

1 Search for “Choosing a Line Style” in Quartus II Help for information on how to change the line weight.

3-5. Double-click the Input symbol next to the pin_name label in the Block Editor window.

This will highlight the pin_name text, allowing you to change the pin name.

3-6. Enter the input name into the Input Pin symbol.

1 The input pin name Must be the same name as the corresponding port on the Reed-Solomon symbol 
name to work with the Altera-provided vector files (in a later step). For example, if the Reed-Solomon 
symbol signal name is rsin[8..1], you must name the input pin rsin[8..1].

3-7. Click OK. The default voltage is the pin voltage if no external device drives it to another value. Leave this value 
at the default, which is VCC.

3-8. Add input pins for all of the Reed-Solomon block inputs. 

1 Ensure that all pin names match those on the Reed-Solomon symbol.
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3-9. Repeat step 3-1. through step 3-7. for the output pin (entering output in the Symbol dialog box Name box). 
Figure 3 shows the completed design.

3-10.In a .bdf, thick lines represent a bus of two or more bits, and thin lines represent a single-bit bus. The rsin and 
rsout pins must be connected by using the “bus line” style, as follows:

a. Place your mouse cursor over the line connecting the rsin (8...1) pin, with the rsin (8...1) port
on the RS symbol.

b. While the cursor is over that line, right-click your mouse and choose the Busline option.

c. Repeat steps (a) and (b) for the output pins connection.

Figure 3. Reed-Solomon Encoder BDF

4. Compile the Design

The next step is to analyze and synthesize the design so that you can perform functional simulation. During this step, 
the Quartus II software synthesizes your design but does not perform place-and-route. Perform the following steps to 
compile.

4-1. Choose Processing > Start Analysis & Synthesis.

4-2. If you have not saved your .bdf file, a message will be displayed, stating “Save changes to rs_encoder.bdf.”

Compilation stops if the Compiler issues any errors. The Status window shows the compilation progress and the 
Message window displays messages and errors. You can find help on any error message by right clicking on the 
message and choosing Help. To locate an error in your design, double-click on the error message.

1 For a more detailed explanation on how to compile a design, refer to “Session 8: Compile the Design” in the 
Quartus II Tutorial.

Figure 4 shows the messages you receive while compiling. 
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Figure 4. Reed-Solomon Encoder Compilation Messages

1 If you are evaluating the Reed-Solomon core using the OpenCore feature, you will also receive warning 
messages that the Compiler cannot generate programming files. These warnings do not affect the lab.

5. Simulate the Design

In this step, you will use an Altera-provided vector file to simulate the design. 

5-1. Choose Assignments > Settings.

5-2. Click the Mode option, under the Simulator settings, on the left side of the window.

5-3. Select Functional from the Simulation mode drop-down list.

5-4. Select the Time/Vectors option, under the Simulator settings, on the left side of the window.

5-5. Click the Browse (...) button in the Vectors box.

5-6. Browse to the c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise1 directory.

5-7. Select the RS_Encoder.vwf file and click Open. 

The signal names in the vector file correspond to the input/output pin names that you specified in ”3. Add Input 
& Output Pins to Your Design’ on page 5. The stimuli in this file will exercise the Reed Solomon encoder. 

The data bus (rsin[8..1]) consists of 188 bytes (1 through 188), which is the data to which the encoder adds 
check symbols.

The start bit is only held high for the first valid byte of each block of data. 

The file has clock, reset and enable signals. The core resets once at the beginning of the file and is enabled for the 
rest of the simulation. The simulation output appears on the rsout[8..1] bus. 

5-8. Click OK.

5-9. Choose Run Simulation (Processing menu). The Quartus II software analyzes and elaborates the design, and 
then performs simulation.

Info: Found 1 design units and 1 entities in source file c:\quartuswb\qdesigns\reed-solomon\rs_encoder.bdf
Info: Found 1 design units and 1 entities in source file c:\quartuswb\qdesigns\reed-solomon\rs_encoder_block.tdf
Info: Found 1 design units and 1 entities in source file c:\megacore\reed-solomon_compiler-v3.2.0\lib\RS_enc.tdf
Info: Assertion information: Compiling ALTERA’s Reed-Solomon Encoder MegaCore Function
Info: Found 1 design units and 1 entities in source file C:\quartusWB\libraries\megafunctions\lpm_counter.tdf
Info: Found 1 design units and 1 entities in source file C:\quartusWB\libraries\megafunctions\alt_synch_counter.tdf
Info: Found 1 design units and 1 entities in source file c:\megacore\reed-solomon_compiler-v3.2.0\lib\gfmul_cnt.tdf
Info: Implemented 232 device resources
Info: Implemented 8 output pins
Info: Automatically selected device EP20K30ETC144-1 for design rs_encoder
Info: Started 1 fitting attempt on Thu Aug 30 2001 at 14:18:22
Warning: Found pins functioning as undefined clocks and/or memory enables
Info: Clock sysclk has Internal fmax of 108.8 MHz between source register 

rs_encoder_block:inst|RS_enc:RS_enc_component|lpm_counter:count|alt_synch_counter:wysi_counter|q[5] and destination register 
rs_encoder_block:inst|RS_enc:RS_enc_component|reg[12][1] (period= 9.191 ns)

Info: Design rs_encoder: Full compilation was successful. 0 errors, 3 warnings
7
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6. View the Simulation Results

View the simulation results to see the 16 check symbols that were added to the end of each codeword.

6-1. Choose View > Full Screen to expand the simulation view. 

You can zoom in by pressing the Ctrl + Space Bar keys; zoom out by pressing the Ctrl, Shift + Space Bar keys. 

6-2. Zoom all the way out. See Figure 5.

Figure 5. Simulation Zoomed Out

6-3. Zoom in on the first codeword to see the check symbols. The data symbols in this project are the numbers 1 
through 188. The first check symbol immediately follows the 188 value. See Figure 6.

1 To locate a particular codeword, zoom out so that the codewords appear as shown in Figure 5. Highlight 
the codeword you want to view and zoom in using the Control + Space Bar keys.

Figure 6. Zoom in to See Check Symbols

Exercise 2: Build a Reed-Solomon Decoder

In this exercise you will create a Reed-Solomon decoder and verify the functionality of the encoder and decoder. The 
decoder corrects up to 8 different errors in the encoded codewords. This exercise involves the following steps:

1. Create a Quartus II project.

2. Generate a Reed-Solomon decoder using the Wizard interface.

3. Add input and output pins to your design.

4. Compile the design.

5. Simulate the design.

First Codeword Second Codeword

Last Data Symbol First Check Symbol Last Check Symbol
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6. View the simulation results.

7. Analyze the throughput.

8. Analyze the effective silicon cost.

1. Create a Quartus II Project

Follow these steps to create a new project. This process is similar to the one in ”1. Create a New Quartus II 2.2 Project’ on 
page 2.

1-1. If you have a project open, choose File > Close Project.

1-2. Create a new BDF named rs_decoder.bdf and save it into the 
c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise2 directory.

1-3. Create a new project based on this file and add the Reed-Solomon user library.

2. Generate a Reed-Solomon Decoder Using the Wizard Interface

Create a Reed-Solomon decoder. This process is similar to the one in ”2. Generate a Reed-Solomon Encoder Using the 
Wizard Interface’ on page 3.

2-1. Launch the MegaWizard Plug-In Manager and create a new megafunction variation.

2-2. Select the Reed-Solomon core, specify a language, and name the output file rs_decoder_block (save it into 
the c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise2 directory).

2-3. On page 1, make the following selections:

– Choose the Decoder option.
– Choose Architecture > Streaming.
– Choose Keysize > Half.

2-4. On page 2, click the DVB Standard button.

You have now finished choosing Wizard settings.

2-5. Click Finish to exit the Wizard, or click Next to view the remainder of the Wizard windows.

1 Wizard page 3 contains a throughput calculator, which you will use in ”7. Analyze Throughput’ on 
page 13 to calculate the decoder’s throughput.

2-6. Insert the symbol into your BDF.

3. Add Input & Output Pins to Your Design

Add input and output pins to the design by performing the following steps:

3-1. Insert a VCC symbol into your design using the same method described in ”3. Add Input & Output Pins to 
Your Design’ on page 5 for Input symbols except type VCC instead of Input in the Name box. Connect the 
VCC symbol to the Reed-Solomon dsout input.

3-2.  Insert a GND symbol (search for GND instead of VCC) and connect it to the Reed-Solomon bypass input.
9
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3-3. Add input and output pins.

1 For the encoder all inputs and outputs must have the same name as the ports in the symbol. However, 
for the decoder, only the single-bit signals must have the same name. The buses must have the same 
number of bits but the bit numbers can be different. 

Name the buses so that the least significant bit is a zero, which makes it simpler to view the simulation 
results. For example, the port rsin[8..1] on the decoder should connect to an input pin named 
rsin[7..0]. In a typical FEC system, the least significant bit is used to determine when valid data is 
on the data bus. It could be used, for example, to synchronize other blocks such as an interleaver. 

Figure 7 shows the completed decoder BDF.

Figure 7. Decoder BDF

4. Compile the Design

The next step is to analyze and synthesize the design, making it possible to run a functional simulation on the 
Reed-Solomon decoder design.

4-1. In the Processing menu, choose the Start > Start Analysis & Synthesis command.

5. Simulate the Design

In this section you will add errors into the Altera-provided Vector Waveform File (.vwf) and then simulate the decoder.

5-1. Choose Open (File menu).

5-2. Select Waveform/Vector Files (*.vwf, *.vec, *.tbl) from the Files of type drop-down list box. 

5-3. Browse to the c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise2 directory.

5-4. Select the RS_Decoder.vwf file and click Open. The encoder you built in exercise 1 works together with the 
decoder you just built. The decoder expects to receive the encoder data and check symbols on the input port 
rsin[8..1]. The RS_Decoder.vwf rsin[7..0] node contains the simulation output from the encoder. The 
codewords, given in the rsin node, all consist of the same data symbols (1 through 188) plus the 
corresponding check symbols. 

Leave the first codeword as is: it will be used to ensure that all of the signals have the appropriate check 
symbols appended to them. This decoder input (the rsin node) has exactly the same values as the encoder 
rsout node in Figure 6 on page 8. 
10



Altera Corporation Reed-Solomon Lab White Paper
1 To locate a particular codeword, zoom out so that the codewords appear as shown in Figure 5 on page 8. 
Highlight the codeword you want to view and zoom in using the Control + Space Bar keys.

5-5. In the second codeword, change any 8 of the values. You can make the values all zeros, all ones, or any value 
except the current one. After simulating, you will check the values to make sure the decoder is correcting up to 
8 errors per codeword—because the decoder has 16 check symbols, they should all be corrected. Refer to 
Figure 6 on page 8 to see where the codewords are located. To change a value, perform the following steps. 

a. The Waveform Editor toolbar should be visible. If it is not, choose Toolbars (Tools) menu and ensure that the
Waveform Editor option is turned on. Click OK. The tool bar buttons are grayed out until you highlight a
signal in the waveform. 

b. Select the portion of the waveform value you want to change by double-clicking on the waveform interval
(you can also select it with the mouse). The interval is highlighted. Only select the node that you want to
change—the simulations do not work properly if you select portions of the waveform that are above or below
the rsin[7..0] signal. See Figure 8.

Figure 8. Editing the Waveform

c. Click the Arbitrary Value icon in the Waveform Editor toolbar.

d. Enter a number between 0 and 255 in the Numeric or named value box.

e. Click OK. The new value displays in the waveform.

5-6. In the third codeword, change more than 8 values using the same process as described for the second 
codeword. After simulating you will view this codeword to see how the decoder fails when it receives too 
many errors per codeword. 

5-7. Choose Save As (File menu).

5-8. Browse to the c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise2 directory.

5-9. Type my_RS_Decoder.vwf in the File name box.

Highlighted Waveform Interval

Arbitrary
Value Icon
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5-10. Click Save.

5-11. Choose Assignment > Settings.

5-12. Under the Simulator Settings (on the left of the window), click the Mode option.

5-13. Select the Simulation mode drop-down list, and select Functional.

5-14. Under the Simulator Settings (on the left of the window), click the Time/Vectors tab.

5-15. Click the Browse (...) button in the Vectors box.

5-16. Browse to the c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise2 directory.

5-17. Select the my_RS_Decoder.vwf file and click Open. 

The signal names in the vector file correspond to the input/output pin names that you specified in ”3. Add 
Input & Output Pins to Your Design’ on page 9.

5-18. Click OK.

5-19. Choose Run Simulation (Processing menu). The simulation runs for five to ten minutes, depending on the 
speed of your PC. You will receive a message when simulation is complete. 

1 You will receive warning messages regarding asynchronous resets during the simulation. These are due to the 
internal operation of the Reed-Solomon Decoder, and they will not affect the simulation results.

6. View the Simulation Results

The decoder uses the check symbols that the encoder appended to the data symbols to correct any errors that were 
introduced into the data stream; it can correct 1 error for every 2 check symbols. The decoder asserts a signal 
(outvalid) when valid data is output on the rsout[8..1] port. The decoder has a three codeword latency, i.e., it 
must receive three codewords before the first one is output. Refer to the Reed-Solomon MegaCore Function User Guide for 
complete information on the Reed-Solomon compiler core operation. Table 1 describes the functionality of the decoder 
signals used in this exercise.

Table 1. Reed-Solomon Decoder Signals

Signal Direction Description

sysclk Input System clock.

reset Input Decoder reset. The discrete decoder must be reset between each codeword.

rsin[] Input m-bit wide input data bus.

bypass Input When asserted, the decoder outputs the uncorrected input data instead of the corrected data. All 
other operations are unaffected and the decoder’s latency remains the same.

rsout[] Output m-bit wide output data bus. 

decfail Output Asserted at the beginning of a data output when the decoder has detected errors and cannot 
correct them.

numerr[] Output Number of symbol errors found. Displays up to the maximum number of correctable errors.

dsin Input Data input control. Data input only takes place in clock cycles when dsin is asserted. In the 
discrete and streaming decoders dsin must remain de-asserted for at least one clock cycle after 
reset is de-asserted.

dsout Input Data output control. Data can be output when dsout is asserted. If dsout is not asserted, data 
is not output. There is a three-cycle latency between a change in dsout and the time when the 
output starts and stops.

rdyin Output Indicates the decoder is ready to accept a new codeword.

outvalid Output Asserted when the decoder outputs a codeword.
12



Altera Corporation Reed-Solomon Lab White Paper
Perform the following steps to view the simulation results, verifying whether the decoder is working properly. 

6-1. Choose Processing > Open Simulation Report.

6-2. Search through the Simulation Report (.vwf) to find where the outvalid signal goes high for the first time. 
Confirm that the values 1 through 188, plus the check symbols, all occur while the outvalid signal is high.

6-3. Check the second codeword. 
Confirm that the values 1 through 8 that you changed in step 5 are corrected. Confirm that the numerr signal 
appropriately reports the number of errors that were corrected.

6-4. Check the third codeword. Confirm that the decoder did fail, and that the numerr signal is correct.

7. Analyze Throughput

In this portion of the lab you will determine the throughput of the FEC system using the decoder simulation results. 
The first step is to specify a specific device in which to implement the design and run a full compile. After compilation, 
the Quartus II software reports the design’s fMAX, which is the maximum clock frequency the decoder can achieve 
without setting design constraints. To determine the decoder throughput, perform the following steps.

7-1. Choose Assignments > Device.

7-2. Select Stratix in the Family drop-down list box.

7-3. Click No if you are asked if you want to allow the Compiler to select a device automatically.

7-4. Select the EP1S25F780C5 or EP1S80B956C6 device under Available devices, depending on which board 
you are using.

7-5. Click OK.

7-6. Choose Start Compilation (Processing menu) to begin a full compilation. 

The Quartus II v2.2 software analyzes and elaborates the design, and fits it into the target device. The Quartus 
II Timing Analyzer reports the fastest clock speed at which the logic runs. The design’s fMAX is displayed in 
the Message Window. You can also perform the following steps to view the fMAX.

a. Choose Open Compilation Report (Processing menu).

b. Expand Timing Analyses.

c. Click fmax (not incl. delays to/from pins).

d. Scroll all the way to the right to view the fMAX for sysclk.

You will use this speed for the throughput analysis.

7-7. Page 3 of the decoder wizard has a throughput calculator. Using the clock frequency you found in step 8, 
calculate your system throughput, as follows.

a. Launch the decoder Megawizard.

b. Open your .bdf file and double-click the Reed-Solomon symbol to launch the MegaWizard.

c. Click Next to page 3.
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1 The throughput calculator expects the fMAX to be in MHz.

The following steps explain how the calculator calculates the throughput, assuming a 150-MHz fMAX. The design has 
204 bytes (188 data symbols and 16 check symbols) that are processed at the rate of one byte per clock cycle. The 
throughput of the system can be found by multiplying the clock frequency times the size of the codewords, and then 
dividing by the number of clock cycles needed to process a codeword. In this example the Reed-Solomon throughput 
calculator assumes that there will be a sixteen-clock cycle gap between codewords. Thus, (204 x 150 MHz) / (204 + 16) 
= 139.09 mega-symbols per second.

8. Analyze the Effective Silicon Cost

In this portion of the lab you will determine the effective silicon cost of the FEC system. Altera Stratix devices are made 
up of logic elements (LEs) that perform the necessary digital logic manipulation. The more LEs a design uses, the bigger 
the device needed. Therefore, the amount of logic in a design dictates the effective silicon cost. You can determine the 
number of LEs your design uses by looking at the Quartus II Report File when compilation completes.

8-1. Determine the resource usage for the decoder.

a. Choose Open Compilation Report (Processing menu)

b. Expand Resource Section.

c. Click Resource Usage Summary to view the number of LEs used. (The design uses roughly 2,171 LEs.

d. Choose Close Project (File menu) when you are done.

8-2. Determine the resource usage for the encoder.

a. Open the encoder project.

b. Perform a full compilation (you can specify the same device you used for the encoder or let the Quartus II 
Compiler choose one automatically).

c. Open the compilation report and view the LEs used. (The design uses roughly 209 LEs.).

8-3. Add the LEs used for the encoder and decoder. This number is the total number of LEs required for the entire 
FEC system.

8-4. You can calculate the effective silicon cost by multiplying the percentage of LEs used times the device price. 
For example, you can implement the 983 Mbit/second, 2,171-LE decoder design on an Altera EP1C3 
Cyclone™ device (which has 2,910 LEs) for $7.

Exercise 3: The Reed-Solomon Demonstration

The Altera Reed-Solomon demonstration shows the benefits of using Altera’s forward error correction (FEC) solutions. 
The demonstration consists of a Windows application in which you specify a picture to transmit over a channel using 
the Reed-Solomon encoder/decoder. You can use this application to alter the type and intensity of errors inserted into 
the data as it passes through the channel. The DSP development board implements the hardware portion of the design, 
which includes the encoder, decoder, and channel. 

After you select the picture and error type, the bytes representing the colors of the pixels within the picture are 
transmitted to the board via an RS-232 port. The data is loaded into a Nios™ embedded processor, which stores it in a 
FIFO buffer. The data is read out of the FIFO buffer and processed in two ways, as follows.

■ One data path goes through the selected channel only and the picture is displayed in the GUI with the errors 
visible.
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■ The other data path goes through the Reed-Solomon encoder, through the channel, through the Reed-Solomon 
decoder, and then the picture is displayed in the GUI. 

The MegaCore functions in this demonstration are configured with the following parameters:

■ Half, standard, streaming Reed-Solomon decoder (204, 188)
– 8-bit symbol width
– 204 symbols per codeword (N = 204)
– 16 check symbols (R = 16)

The demonstration runs at 33 MHz, generated by the DSP development board from the 80-MHz clock. Figure 9 
shows an overview of the demonstration setup using the Stratix EP1S25 DSP development board. The setup for the 
Stratix EP1S80 DSP development board is similar.

Figure 9. Reed-Solomon Demonstration Setup (Stratix EP1S25 DSP Development Board)

Figure 10 shows a block diagram of the design implemented in the Stratix device on the board.
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Figure 10. Block Diagram of Design Implemented in Stratix Device on the Board

Note:
(1)    The interleaver/deinterleaver is added if you select the Burst Errors option and turn on Add Interleaver/Deinterleaver in the application.

Definitions

The following definitions apply to this demonstration only:

■ Symbol—An 8-bit piece of data
■ Codeword—204 bytes consisting of 188 data symbols and 16 Reed-Solomon check symbols
■ Check symbol—A symbol that the Reed-Solomon encoder adds to the data so the decoder can correct any errors that 

occur during the data transmission
■ Data packet—A 940-byte piece of data
■ BER—Bit error rate

1. Connect the Cables to the Board

Before running the demonstration, you must connect cables to the DSP development board. Refer to the getting 
started user guide for detailed instructions on how to connect the cables to the board. Perform the following steps to 
connect the cables:

1-1. Connect the power adapter cable to the board and plug it into a power outlet.

1-2. Connect the  ByteBlaster II cable to your PC and to the board’s 10-pin JTAG header for Stratix configuration.

1-3. Connect an RS-232 cable to your PC and to the board.

2. Configure the Stratix Device

Perform the following steps to configure the device:

2-1. Choose Programs > Altera > Quartus II 2.2 Limited Edition (Windows Start Menu) or Programs > Altera > 
Quartus II 2.2 (Windows Start Menu).

2-2. Choose Programmer (Tools menu). 
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2-3. Click Add File.

2-4. Browse to the c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise3\sof directory.

2-5. Select the file Reed-Solomon_Demo_v3_stratix.sof.

2-6. Click Open.

2-7. Turn on the Program/Configure option.

2-8. Click Start to configure the Stratix device. 

3. Run the Demonstration

This section describes how to run the demonstration. The application does not display properly on systems that use 
large fonts. To change your font settings, perform the following steps. If you are already using small fonts, skip to step 7.

3-1. Choose Settings > Control Panel (Windows Start menu).

3-2. Double-click the Display icon.

3-3. Click the Settings tab.

3-4. Choose Small Fonts under Font Size.

3-5. Click OK.

3-6. Reboot your system for the changes to take effect.

3-7. Execute the file 
c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise3\Reed-Solomon_Demo_v3.exe to start 
the demonstration software.

3-8. Click the PC Options button, indicate which COM port you are using, and click OK.

3-9. Select the picture to transmit in the Picture Selection box. 

1 If you prefer, you can use a picture of your choice instead of the ones provided with the demonstration. 
See ”6. Adding a Custom Picture’ on page 19 for more details. 

3-10.Select the error type in the Error Selection box (The demonstration provides several types of errors that can be 
injected into the channel. See “5. Error Channels” on page 18. for more details, and click Start. 

1 The flashing LED flashes twice as fast while the data is being processed.

The data paths are shown in the block diagram in the demonstration software GUI. The transmitted pictures are 
displayed as the data bits are processed. See Figure 11.
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Figure 11. Reed-Solomon Demonstration User Interface

4. Transmission Details

Each bitmap image transmitted in this demonstration has three data bytes representing each pixel. Data is transmitted 
in blocks of 5 Reed-Solomon codewords (188 bytes each for a total data packet of 940 bytes). After a block is transmitted 
to the board and processed, it is sent back to the demonstration software and displayed in the appropriate window 
before another data packet is sent. A 16-bit Nios embedded processor receives the data using a UART peripheral from 
the Nios peripheral library. The Nios processor writes the data into a memory-mapped FIFO buffer, where it is read out 
and passed to the appropriate data path. Then, the data is written to a pair of memory-mapped FIFO buffers from which 
the Nios processor reads the data and sends it back to the PC.

5. Error Channels

You can choose from three provided error channels. The Max Errors channel deterministically injects 8 errors into each 
Reed-Solomon codeword. The Reed-Solomon encoder used in this implementation has 16 check symbols, which 
supports the detection and correction of up to 8 errors per codeword. Therefore, the Max Errors channel option injects 
the maximum number of errors into the data path that the Reed-Solomon decoder can correct.

The Variable BER channel lets you select one of several different bit error rates (BERs). This channel injects errors 
routinely into each codeword, spreading the errors farther apart as lower BERs are selected. The highest BER setting 
adds 12 symbol errors to each codeword, which is more than this implementation of the Reed-Solomon core can correct. 
Therefore, this setting causes the Reed-Solomon decoder to fail, and both of the transmitted pictures return with errors.
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6. Adding a Custom Picture

All bitmaps of the same size have the same structure, therefore you can create a custom picture to transmit. Save your 
image as my_file.bmp in the 
c:\MegaCore\stratix_dsp_kit-v1.0.0\Labs\Error_Correction\Exercise3\application\bmps directory. The image 
must be 183 pixels wide by 260 pixels tall. 

For example, you can create an image using the Microsoft Paint software by performing the following steps:

6-1. View the image on your PC, for example in a web browser or other viewer.

6-2. Press the Print Screen button on your keyboard to copy the image to the clipboard.

6-3. Open Paint and paste the clipboard contents into a new file. 

6-4. Choose the Attributes command (Image menu), set the height to 260 pixels and the width to 183 pixels, and 
click OK. If your current picture is bigger than the new size, it is cut from the right side and bottom to fit within 
the smaller area. If the current picture is smaller than the new size, the extra area is filled with the selected 
background color. 
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