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この資料は英語版を翻訳したもので、内容に相違が生じる場合には原文を優先します。こちらの日本語版は参考用としてご利用
ください。設計の際には、最新の英語版で内容をご確認ください。

1. 概要

はじめに この章では、ソフトウェア開発者を対象に Nios® IIプロセッサの概要を
説明します。Nios II ソフトウェア開発環境、Nios II エンベデッド・デ
ザイン・スイート（EDS）ツール、およびソフトウェア開発のプロセス
を紹介します。この章は、以下の項で構成されています。

■ 1-1ページの「最新情報」
■ 1-2ページの「使用開始にあたって」
■ 1-3ページの「Nios IIソフトウェア開発環境」
■ 1-3ページの「Nios IIプログラム」
■ 1-6ページの「Nios IIプログラム作成のためのデザイン・フロー」
■ 1-10ページの「追加 EDSサポート」
■ 1-10ページの「サードパーティ・サポート」
■ 1-10ページの「第 1世代のNiosプロセッサからの移行」
■ 1-11ページの「Nios IIに関するその他の情報」

最新情報 以下の機能はNios II EDS v8.0の新機能です。

■ .sopcinfoファイル—v8.0から導入。SOPC Builderのシステム・ファ
イルは .sopcファイルではなく、.sopcinfoファイルとしてエンコー
ドされます。.sopcinfo ファイルは、SOPC Builderでシステム生成
を実行するときに生成されます。.sopcinfoファイルは、スタティッ
ク・ファイルであり、生成時にインストールされる IPコンポーネン
トに基づいてシステムの生成方法を記述しています。以前は .sopc
ファイルを入力として受け入れていたユーティリティ（nios2-bsp-
create-settings など）は、v8.0 からは .sopcinfo ファイルを受け入
れます。

--sopcコマンドライン引数は、.sopcファイルではなく .sopcinfo
ファイルをサポートします。

SOPC Builder リリース 7.2 またはそれ以前のリリースで
ハードウェアが生成されている場合、BSPを作成する前に
SOPC Builderリリース 8.0で再生成してください。

BSPエディタ—コマンドラインNios IIソフトウェア・ビルド・ツール以
外に、BSPプロジェクトを作成する別の方法は、スタンドアロンのグラ
フィカル・ユーザー・インタフェース （GUI）である Nios II BSPエディ
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タを使用することです。BSPエディタは、ソフトウェア・ビルド・ツー
ルをドライブするグラフィカル・フロント・エンドを提供します。Nios II
BSPエディタを起動するには、次のコマンドを使用します。

nios2-bsp-editor

BSPエディタの使用法について詳しくは、ツールを起動し
て画面上の説明文を参照してください。 

■ ウェブ上で配布されるソフトウェア例—Nios II IDEのv7.2まで配布
されていた特定のソフトウェア例は、v8.0からはウェブ上で配布さ
れます。ウェブで入手可能なソフトウェア例は、以下のとおりです。

Nios IIプロセッサ・コアは、オプションのメモリ・マネージメ
ント・ユニット（MMU）を備えています。Nios II HAL（Hardware
Abstraction Layer）は、MMUをサポートしていません。

使用開始
にあたって 

Nios IIプロセッサ用ソフトウェアの作成は、他社のマイクロコントロー
ラ・ファミリのソフトウェア開発プロセスと似ています。アルテラから
開発キットを購入することで、簡単かつ効率的に設計を開始することが
できます。この開発キットには、資料、既成の開発ボード、およびNios II
プログラムを作成するのに必要なすべての開発ツールが含まれていま
す。

Nios IIソフトウェア開発ハンドブックでは、読者にエンベデッド・プロ
セッサのコンセプトに関する基本的な知識があることを想定して作成さ
れていますが、アルテラの特定のテクノロジやアルテラの開発ツールに
関する知識は必要ありません。アルテラ・ハードウェア開発ツールに関
する知識があると、Nios IIソフトウェア開発環境の背景にある論理をよ

例の名称 場所

Zipファイル・システム Nios Community Wiki

MicroC/OS-IIメッセージ •ボックス Nios Community Wiki

Hello LED Nios Community Wiki

ホスト・ファイル・システム Nios Community Wiki

Dhrystone www.altera.co.jp

MicroC/OS-IIチュートリアル www.altera.co.jp

密結合メモリ www.altera.co.jp

カスタム命令チュートリアル www.altera.co.jp

http://nioswiki.jot.com/WikiHome
http://nioswiki.jot.com/WikiHome
http://nioswiki.jot.com/WikiHome
http://nioswiki.jot.com/WikiHome
http://www.altera.com/
http://www.altera.com/
http://www.altera.com/
http://www.altera.com/
http://www.altera.co.jp/search?output=xml_no_dtd&sort=date%3AD%3AL%3Ad1&client=japan_frontend&proxystylesheet=japan_frontend&ie=UTF-8&oe=UTF-8&site=japan&q=Nios%20Community%20Wiki
http://www.altera.co.jp/search?output=xml_no_dtd&sort=date%3AD%3AL%3Ad1&client=japan_frontend&proxystylesheet=japan_frontend&ie=UTF-8&oe=UTF-8&site=japan&q=Nios%20Community%20Wiki
http://www.altera.co.jp/search?output=xml_no_dtd&sort=date%3AD%3AL%3Ad1&client=japan_frontend&proxystylesheet=japan_frontend&ie=UTF-8&oe=UTF-8&site=japan&q=Nios%20Community%20Wiki
http://www.altera.co.jp/search?output=xml_no_dtd&sort=date%3AD%3AL%3Ad1&client=japan_frontend&proxystylesheet=japan_frontend&ie=UTF-8&oe=UTF-8&site=japan&q=Nios%20Community%20Wiki
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り深く理解することができます。ただし、ソフトウェア開発者は、アル
テラ・テクノロジの知識がなくても、アプリケーションの開発やデバッ
グを行うことができます。

ソフトウェア設計者が新しい環境でプログラムの作成方法を取得するに
は、おそらく既存のコードを書き換えるのが最も一般的で安心できる方
法と考えられます。Nios II EDS は、ソフトウェア設計例を提供してお
り、設計者はこれらを自身のプログラムで検証、修正、および使用でき
ます。提供されている例は、単純な Hello worldプログラムから実用的
なリアル・タイム・オペレーティング・システム（RTOS）の例、そし
てウェブ・サーバーを稼動させる完全な TCP/IP（Transmission Control
Protocol/Internet Protocol）スタックなど、広範囲に及びます。それぞ
れの例は、ドキュメント化されており、すぐにコンパイルできます。

Nios II
ソフトウェア
開発環境

Nios II EDSは、すべてのNios IIプロセッサ・システムに役立つ一貫性
のあるソフトウェア開発環境を提供します。PC、アルテラ FPGA、およ
び JTAG（Joint Test Action Group）ダウンロード・ケーブル（アルテラ
の USB-Blaster™ ダウンロード・ケーブルなど）を使用して、任意の
Nios IIプロセッサ・システムのためにプログラムを記述したり、それと
通信することができます。Nios IIプロセッサの JTAGデバッグ・モジュー
ルは、JTAG ダウンロード・ケーブルを使用してプロセッサと通信する
ための一貫性のある 1 つの方法を提供します。デバイスが Nios II プロ
セッサ・システムのみを実装しているかどうか、または Nios IIプロセッ
サが複雑なマルチプロセッサ・システムに深く埋め込まれているかどう
かに関係なく、プロセッサへのアクセスは同じです。したがって、エン
ベデッド・プロセッサのためにインタフェース・メカニズムを手動で作
成する時間は必要ありません。

Nios II EDS は異なる 2 つのデザイン・フローを提供し、Nios II プログ
ラムを作成するための独自のオープン・ソース・ツール（GNU C/C++
ツール一式など）を多数備えています。Nios II EDS は、Nios II-をベー
スとしたシステムのためのボード・サポート・パッケージ（BSP）作成
を自動化しており、BSPを手動で作成するための時間は不要です。アル
テラの BSPには、アルテラのHAL（Hardware Abstraction Layer）、オ
プションの RTOS、およびデバイス・ドライバが含まれています。BSP
は C/C++ ランタイム環境を提供し、エンベデッド・システムのハード
ウェアからユーザーを隔離します。

Nios II
プログラム

いずれかのNios II EDSデザイン・フローで開発する各 Nios IIプログラ
ムは、アプリケーション・プロジェクト、オプションのライブラリ・プ
ロジェクト、および BSPプロジェクトで構成されます。Nios IIプログラ
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ムを、Nios II プロセッサ上で動作する Executable And Linked Format
File (.elf)に作成します。2つのデザイン・フローで専門用語が異なるこ
とがありますが、開発する Nios IIプログラムは概念的には同じです。

以下の項では、Nios IIプログラムを構成するプロジェクトのタイプにつ
いて説明します。

アプリケーション・プロジェクト
Nios II C/C++ アプリケーション・プロジェクトは、1 つの実行（.elf ）
ファイルに結合されたソース・コードの集合から成ります。アプリケー
ションの標準的な特色は、ソース・ファイルの 1つに関数 main()が含
まれていることです。アプリケーションには、ライブラリおよび BSPで
関数を呼び出すコードが含まれています。

ライブラリ・プロジェクト
ライブラリ・プロジェクトは、1つのライブラリ・アーカイブ（.a）ファ
イル内に含まれるソース・コードの集合です。ライブラリには多くの場
合、再使用可能で、複数のアプリケーションが共有できる汎用関数が含
まれています。一般的な演算関数の集合が 1つの例です。ライブラリに
は関数 main()は含まれていません。

BSPプロジェクト
Nios II BSPプロジェクトは、システム固有のサポート・コードを含む特
殊なライブラリです。BSP は SOPC Builder システムで 1 個のプロセッ
サに対してカスタマイズされた、ソフトウェア・ランタイム環境を提供
します。Nios II EDSは、BSPの動作をコントロールする設定を変更する
ためのツールを提供します。

Nios II 統合開発環境（IDE）および Nios II IDE デザイン・フ
ローの資料では、BSPを表すときに、“システム・ライブラリ”
という用語を使用しています。

BSPは以下の要素で構成されています。

■ HAL（Hardware Abstraction Layer）
■ Newlib C標準ライブラリ
■ デバイス・ドライバ
■ オプションのソフトウェア・パッケージ
■ オプションのリアル・タイム・オペレーティング・システム（RTOS）
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HAL（Hardware Abstraction Layer）

HALは非スレッドのUNIXライクなC/C++ランタイム環境を提供しま
す。HALによって一般的な I/Oデバイスが提供されるため、printf()
などの newlib C標準ライブラリ・ルーチンを使用して、ハードウェアに
アクセスするプログラムを作成できます。HALにより、ペリフェラルを
制御したり、ペリフェラルと交信するために直接ハードウェア・レジス
タにアクセスする必要性が最小限（あるいはまったく不要）になります。

HAL について詳しくは、「Nios II ソフトウェア開発ハンドブック」の
「The Hardware Abstraction Layer」 セクションおよび 「HAL APIリファ
レンス」 の章を参照してください。

Newlib C標準ライブラリ

Newlib は、エンベデッド・システムでの使用を意図した C 標準ライブ
ラリのオープン・ソース実装です。printf()、malloc()、および
open()などの一般的なルーチンの集合です。

デバイス・ドライバ

各デバイス・ドライバは、ハードウェア・コンポーネントを管理します。
デフォルトにより、HAL はデバイス・ドライバを必要とする SOPC
Builder システムの各コンポーネント用デバイス・ドライバをインスタ
ンス化します。Nios IIソフトウェア開発環境では、デバイス・ドライバ
は以下の特性を備えています。

■ デバイス・ドライバは特定の SOPC Builderコンポーネントに関連付
けられています。

■ デバイス・ドライバには、コンパイルに影響を与える設定がある場
合があります。これらの設定は BSP設定の一部になります。

オプションのソフトウェア・パッケージ

ソフトウェア・パッケージは、付加機能を提供するためにオプションで
BSPプロジェクトに追加できるソース・コードです。NicheStack® TCP/IP -
Nios II Editionは、ソフトウェア・パッケージの一例です。

Nios II IDEおよびNios II IDEデザイン・フローの資料では、ソ
フトウェア・パッケージを表すときに“ソフトウェア・コンポー
ネント”という用語を使用しています。

Nios IIソフトウェア開発環境では、ソフトウェア・パッケージは一般に
以下の特性を備えています。

http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.com/literature/hb/nios2/n2sw_nii5v2_02.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_02_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii52010_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii52010_j.pdf
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■ ソフトウェア・パッケージは特定のハードウェアに関連していませ
ん。

■ ソフトウェア・パッケージには、コンパイルに影響を与える設定が
ある場合があります。これらの設定は BSP設定の一部になります。

Nios IIソフトウェア開発環境では、ソフトウェア・パッケージ
はライブラリ・プロジェクトとは区別されます。ソフトウェア・
パッケージは BSP プロジェクトの一部で、独立したライブラ
リ・プロジェクトではありません。

オプションのリアル・タイム・オペレーティング・システム
（RTOS）

Nios II EDSには、オプションで BSPに組み込むことができるサードパー
ティのMicroC/OS-II RTOSの実装が含まれています。MicroC/OS-IIは
HAL 上に構築され、簡単で十分に実証された RTOS スケジューラを実
装しています。BSP設定の一部となる設定を変更できます。サードパー
ティ・ベンダからオペレーティング・システムを入手できます。

Nios II
プログラム
作成のため
のデザイン・
フロー

Nios II EDS は、Nios II プログラム作成用の 2 種類のデザイン・フロー
を提供しています。Nios II統合開発環境（IDE）内ですべて作業を行う
か、コマンドラインやスクリプト化された環境でNios IIソフトウェア・
ビルド・ツールを使用した後、デザインを IDEにインポートしてデバッ
グすることができます。

この 2つのデザイン・フローを置き換えることはできません。アプリケー
ション、ライブラリ、およびドライバのソース・コードは、どちらのフ
ローでも動作しますが、2つのフローのmakefileは異なり、互換性はあ
りません。1 つのデザイン・フローを使用することに決めた場合、その
プロジェクトで別のデザイン・フローを使用するには、最初からやり直
さなければなりません。

Nios II IDEデザイン・フロー
Nios II IDEデザイン・フローでは、Nios II IDEグラフィカル・ユーザー・
インタフェース（GUI）を使用して、Nios IIプログラムを作成し、変更、
構築、実行し、デバッグします。IDE はユーザー用にプロジェクトの
makefileを作成し、管理します。このデザイン・フローは、構築された
プロセスおよびプロジェクト設定を限定的に制御するだけの場合に最適
で、カスタマイズされたスクリプトは必要ありません。
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Nios II IDEは、一般的な Eclipse IDEフレームワークと Eclipse C/C++
開発ツール・キット（CDT）プラグインをベースにしています。Nios II
IDEは、バックグラウンドで他のツールを動作させ、低レベル・ツール
の詳細からユーザーを遮蔽し、統一された開発環境を提供します。

Nios II IDEは、プロジェクトの作成およびコンフィギュレーションに役
立つウィザードを備えており、使いやすく、特に Nios IIの初心者にとっ
て便利です。Nios II IDEは、Windowsおよび Linuxオペレーティング・
システムの両方で使用できます。

Nios II IDEについて詳しくは、「Nios IIソフトウェア開発ハンドブック」
の「Nios II Integrated Development Environment」 の章を参照してくだ
さい。

Nios IIソフトウェア・ビルド・ツールのデザイン・フロー
Nios IIソフトウェア・ビルド・ツールのデザイン・フローでは、コマン
ドラインに入力するか、またはスクリプトに記述されたコマンドを使用
して、Nios IIプログラムを作成し、変更、構築し、実行します。このデ
ザイン・フローは、構築されたプロセスおよびプロジェクト設定に対し
て緻密なコントロールが必要な場合、またはカスタマイズされたスクリ
プトが必要な場合に最適です。

Nios II ソフトウェア・ビルド・ツールは、Nios II IDE の New Project
ウィザードおよび System Libraryプロパティ・ページに、同様の機能を
提供するユーティリティおよびスクリプトです。Nios IIソフトウェア・
ビルド・ツールのデザイン・フローにより、Nios IIソフトウェア開発を
開発フローの他の部分と統合できます。スクリプトを使用すると、ソフ
トウェア開発フローは完全に繰り返し可能かつアーカイブ可能になりま
す。 

デバッグ時には、Nios IIソフトウェア・ビルド・ツールのプロジェクト
を Nios II IDE プロジェクトとして IDE にインポートして、デバッグを
行います。IDEでインポートされたアプリケーション・プロジェクトを
さらに編集し、再構築、実行し、デバッグすることができます。また、
ライブラリおよび BSPプロジェクトをインポートして、デバッガでソー
ス・コードを表示することも可能ですが、インポートされたライブラリ
および BSPプロジェクトは IDEで直接構築することはできません。

Nios II IDEと同様に、Nios IIソフトウェア・ビルド・ツールはWindows
および Linuxオペレーティング・システムの両方で使用できます。Nios II
ソフトウェア・ビルド・ツールは、アルテラの将来の Nios II 開発の基
礎となるものです。

http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii52002_j.pdf
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Nios IIソフトウェア・ビルド・ツールについて詳しくは、「Nios IIソフ
トウェア開発ハンドブック」の「Introduction to the Nios II Software
Build Tools」の章を参照してください。

デザイン・フロー・ツール
この項では、各デザイン・フローのための Nios II プログラムの作成に
使用するツールを紹介します。ここで示す表は必要なレベルのコント
ロールを決定するのに役立つように構成されています。これらの表をク
イック・リファレンス・ガイドとして使用して、デザイン・フロー間の
違いを把握することができます。

表 1–1 に、各 Nios II デザイン・フローでのタスクに対して、高度に自
動化されたレベルのコントロールを提供するツールを示します。このレ
ベルのコントロールでは、Nios II プログラム例全体（アプリケーショ
ン・プロジェクトと BSP プロジェクトから成る）、またはデフォルト設
定を使用したアルテラ提供ソフトウェア例からのBSPプロジェクト例だ
けを作成します。この高度に自動化されたツールは、開発の出発点とし
て、あるいはカスタマイズが不要なときに使用します。

表 1–2 に、各 Nios II デザイン・フローでのタスクに対する中間レベル
のコントロールを提供するツールを示します。このレベルのコントロー
ルでは、カスタム・コードまたはアルテラが提供するソフトウェア例か

表 1–1.高度に自動化されたデザイン・フロー・ツール

タスク Nios II IDEデザイン・フロー Nios IIソフトウェア・ビルド・
ツールのデザイン・フロー

Nios IIプログラム
例の作成

File > New > Nios II C/C++ Application create-this-appスクリプト

BSP例の作成 File > New > Nios II System Library create-this-bspスクリプト

デバッグ Run > Debug As > Nios II Hardware ● File > Import > Altera Nios II >ワークス
ペースに読み込む既存の Nios II ソフト
ウェア・ビルド・ツールのプロジェクト
またはフォルダ

● Run > Debug As > Nios II Hardware

http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii52014_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii52014_j.pdf
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ら Nios II プログラムを作成します。デフォルト設定で得られる以上の
コントロールが必要な場合は、開発の出発点として中間ツールを使用し
ます。

表 1–3に、各 Nios IIデザイン・フローで BSPに関連するタスクに対し
て高度なレベルのコントロールを提供するツールを示します。このレベ
ルのコントロールでは、高機能のスクリプタブル・コントロールを使用
して Nios II BSPを作成します。BSP構築プロセスと BSPプロジェクト
設定に対する全面的なコントロールが必要なときは、高度なツールを使
用します。

表 1–2.中間デザイン・フロー・ツール

タスク Nios II IDEデザイン・フロー Nios IIソフトウェア・ビルド・
ツールのデザイン・フロー

アプリケーション
の構築

File > New > Nios II C/C++ Application nios2-app-generate-makefileユーティリティ

ライブラリ
の構築

File > New > Nios II C/C++ Library nios2-lib-generate-makefileユーティリティ

BSP
の構築

● File > New > Nios II System Library
● Project > Properties > System Library

nios2-bsp スクリプト

デバッグ Run > Debug As > Nios II Hardware ● File > Import > Altera Nios II >ワークス
ペースに読み込む既存の Nios II ソフト
ウェア・ビルド・ツールのプロジェクト
またはフォルダ

● Run > Debug As > Nios II Hardware

表 1–3.高度な BSPデザイン・フロー・ツール

タスク Nios II IDEデザイン・フロー Nios IIソフトウェア・ビルド・
ツールのデザイン・フロー

BSP
の構築

システム・ライブラリ・プロジェクトのスク
リプタブル・コントロールはサポートされて
いません。

● nios2-bsp-create-settingsユーティリティ
● nios2-bsp-generate-filesユーティリティ
● Tclスクリプタブル

BSP
のアップデート

システム・ライブラリ・プロジェクトのスク
リプタブル・コントロールはサポートされて
いません。

● nios2-bsp-update-settingsユーティリティ
● nios2-bsp-generate-filesユーティリティ
● Tclスクリプタブル

BSP
の照会

サポートされていません。 ● nios2-bsp-query-settings ユーティリティ
● Tclスクリプタブル

newlib
のカスタマイズ

サポートされていません。 nios2-bsp スクリプト :
CUSTOM_NEWLIB_FLAGS 設定を使用



1–10 Altera Corporation
Nios IIソフトウェア開発ハンドブック 2008年 5月

追加 EDSサポート

追加 EDS
サポート

Nios II IDEおよびNios IIソフトウェア・ビルド・ツールに加えて、Nios II
EDSには以下のアイテムが含まれています。

■ GNU ツールー式
■ 命令セット・シミュレータ
■ デザイン例

GNU ツールー式
Nios IIのコンパイラ・ツール一式は、標準的な GNU GCCコンパイラ、
アセンブラ、リンカ、およびmake機能をベースにしています。 

GNUついて詳しくは、www.gnu.orgを参照してください。

命令セット・シミュレータ
Nios II 命令セット・シミュレータ（ISS）を使うことで、ターゲットの
ハードウェア・プラットフォームが完成する前に、プログラムの開発を
開始することができます。実際のハードウェア・ターゲット上で実行す
るのと同様に、Nios II IDEから ISSを使用して簡単にプログラムを実行
できます。

デザイン例
Nios_II EDSには、Nios IIプロセッサおよび開発環境のすべての重要な
機能を実証できるように、ソフトウェア事例が提供されています。

サードパーティ・
サポート

サードパーティ・ベンダー数社は Nios II プロセッサをサポートしてお
り、デザイン・サービス、オペレーティング・システム、スタック、そ
の他のソフトウェアライブラリや開発ツールなどを提供しています。

Nios IIプロセッサのサードパーティ・サポートに関する最新情報は、
Nios II プロセッサのホーム・ページ（www.altera.co.jp/nios2）を参照
してください。

第 1世代の
Niosプロセッサ
からの移行

第 1 世代の Nios プロセッサ・ユーザーの方には、今後のデザインでは
Nios IIプロセッサへ移行することをお勧めします。分かりやすい移行プ
ロセスについては、「AN 350: Upgrading Nios Processor Systems to the
Nios II Processor」で説明しています。
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Nios II
に関する
その他の情報

このハンドブックは、Nios IIプロセッサの関連資料の一部です。Nios II
プロセッサに関するその他の情報については、次の参考資料をご覧くだ
さい。

■  Nios II プロセッサ・リファレンス・ハンドブックでは、命令セッ
ト・アーキテクチャを含む、プロセッサのハードウェア・アーキテ
クチャおよび機能が定義されています。

■ Quartus® IIハンドブック Volume 5の「エンベデッド・ペリフェラ
ル」は、Nios IIプロセッサとともに配布されるペリフェラルの参考
資料を提供します。このハンドブックでは、ハードウェア構造と各
ペリフェラル用 Nios II ソフトウェア・ドライバについて説明しま
す。

■ Nios II IDEは、GUIの機能を使用するためのチュートリルと包括的
な情報を提供します。Nios II IDE内ではヘルプ・システムを使用で
きます。

■ アルテラ・ナレッジ・データベースは、使いやすい検索エンジンに
よって、FAQに対する回答を提供するインターネット・リソースで
す。www.altera.co.jp/support/kdb/kdb-index.jsp を参照してくだ
さい。

■ アルテラのアプリケーション・ノートとチュートリアルでは、特定
のアプリケーションまたは目的に対する Nios II プロセッサの使用
方法について段階的に説明しています。これらの資料は、オンライ
ン資料 : Nios IIプロセッサ・ページ（www.altera.co.jp/literature/lit-
nio2.jsp）で提供されています。

参考資料 この章では以下のドキュメントを参照しています。

■ 「The Hardware Abstraction Layer」セクション（Nios IIソフトウェ
ア開発ハンドブック）

■ 「HAL APIリファレンス」の章（Nios IIソフトウェア開発ハンドブッ
ク）

■ 「Nios II Integrated Development Environment」 の章（Nios IIソフト
ウェア開発ハンドブック）

■ 「Introduction to the Nios II Software Build Tools」 の章（Nios IIソフ
トウェア開発ハンドブック）

■ AN 350: Upgrading Nios Processor Systems to the Nios II Processor
■ Nios IIプロセッサ・リファレンス・ハンドブック
■ Quartus IIハンドブック Volume 5: エンベデッド・ペリフェラル

http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_02_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii52010_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii52002_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii52014_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2sw_nii5v2_j.pdf
http://www.altera.co.jp/literature/an/an350_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2cpu_nii5v1_j.pdf
http://www.altera.co.jp/literature/hb/nios2/n2cpu_nii5v3_j.pdf
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改訂履歴

改訂履歴 表 1–4に、本資料の改訂履歴を示します。

表 1–4.改訂履歴

日付およびド
キュメント・
バージョン

変更内容 概要

2008年 5月
v8.0.0

1-1ページの「最新情報」を追加。 ● .sopcinfoファイル
● EDS から削除された
デザイン例

● Nios IIコアにMMUを
追加

2007年 10月
v7.2.0

前バージョンからの内容の変更はありません。 

2007年 5月
v7.1.0

● Nios II EDSデザイン・フロー、Nios IIプログラム、Nios IIソ
フトウェア・ビルド・ツール、および Nios II BSP を紹介す
る章全体を改訂。

● 「はじめに」の項に目次を追加。
● 「参考資料」の項を追加。

Nios IIソフトウェア・
ビルド・ツール

2007年 3月
v7.0.0

前バージョンからの内容の変更はありません。 

2006年 11月
v6.1.0

前バージョンからの内容の変更はありません。 

2006年 5月
v6.0.0

前バージョンからの内容の変更はありません。

2005年 10月
v5.1.0

前バージョンからの内容の変更はありません。

2005年 5月
v5.0.0

前バージョンからの内容の変更はありません。

2004年 5月
v1.0

初版
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